Service Status

Netlify load balancer down

25 Mar 2021 08:49 -0700

Our website is not available according to user reports.

25 Mar 2021 08:55 -0700

Update: Due to a global outage with Netlify’s load balancer, our site will be unavailable for several hours.

25 Mar 2021 09:35 -0700

Update: Netlify has fixed the issue. More available here: https://www.netlifystatus.com/incidents/r2nqshvznvyj

25 Mar 2021 11:59 -0700

Major outage

Affected Systems: ABS Website (bahaistudies.ca), Conference Registration